FreeBSD VuXML: Documenting security issues in FreeBSD and the FreeBSD Ports Collection

pcre -- buffer overflow vulnerability

Affected packages
pcre < 7.6


VuXML ID f9e96930-e6df-11dc-8c6a-00304881ac9a
Discovery 2008-01-28
Entry 2008-02-29

PCRE developers report:

A character class containing a very large number of characters with codepoints greater than 255 (in UTF-8 mode, of course) caused a buffer overflow.


Bugtraq ID 27786
CVE Name CVE-2008-0674