FreeBSD VuXML: Documenting security issues in FreeBSD and the FreeBSD Ports Collection

png -- libpng decompression buffer overflow

Affected packages
png < 1.4.3


VuXML ID edef3f2f-82cf-11df-bcce-0018f3e2eb82
Discovery 2010-03-30
Entry 2010-06-28
Modified 2010-06-28

The PNG project describes the problem in an advisory:

Several versions of libpng through 1.4.2 (and through 1.2.43 in the older series) contain a bug whereby progressive applications such as web browsers (or the rpng2 demo app included in libpng) could receive an extra row of image data beyond the height reported in the header, potentially leading to an out-of-bounds write to memory (depending on how the application is written) and the possibility of execution of an attacker's code with the privileges of the libpng user (including remote compromise in the case of a libpng-based browser visiting a hostile web site).


Bugtraq ID 41174
CVE Name CVE-2010-1205