FreeBSD VuXML: Documenting security issues in FreeBSD and the FreeBSD Ports Collection

apache22 -- several vulnerabilities

Affected packages
2.2.0 < apache < 2.2.12


VuXML ID e15f2356-9139-11de-8f42-001aa0166822
Discovery 2009-07-28
Entry 2009-08-25

Apache ChangeLog reports:

CVE-2009-1891: Fix a potential Denial-of-Service attack against mod_deflate or other modules.

CVE-2009-1195: Prevent the "Includes" Option from being enabled in an .htaccess file if the AllowOverride restrictions do not permit it.

CVE-2009-1890: Fix a potential Denial-of-Service attack against mod_proxy in a reverse proxy configuration.

CVE-2009-1191: mod_proxy_ajp: Avoid delivering content from a previous request which failed to send a request body.

CVE-2009-0023, CVE-2009-1955, CVE-2009-1956: The bundled copy of the APR-util library has been updated, fixing three different security issues which may affect particular configurations and third-party modules (was already fixed in 2.2.11_5).


CVE Name CVE-2009-0023
CVE Name CVE-2009-1191
CVE Name CVE-2009-1195
CVE Name CVE-2009-1890
CVE Name CVE-2009-1891
CVE Name CVE-2009-1955
CVE Name CVE-2009-1956