FreeBSD VuXML: Documenting security issues in FreeBSD and the FreeBSD Ports Collection

mediawiki -- cross site scripting vulnerability

Affected packages
1.10.0 < mediawiki < 1.10.2
1.9.0 < mediawiki < 1.9.4
1.8.0 < mediawiki < 1.8.5


VuXML ID c9c14242-6843-11dc-82b6-02e0185f8d72
Discovery 2007-09-10
Entry 2007-09-21
Modified 2007-10-10

The MediaWiki development team reports:

A possible HTML/XSS injection vector in the API pretty-printing mode has been found and fixed.

The vulnerability may be worked around in an unfixed version by simply disabling the API interface if it is not in use, by adding this to LocalSettings.php:

$wgEnableAPI = false;

(This is the default setting in 1.8.x.)


CVE Name CVE-2007-4828