FreeBSD VuXML: Documenting security issues in FreeBSD and the FreeBSD Ports Collection

poppler -- uninitialized pointer

Affected packages
poppler < 0.8.4_2


VuXML ID bc20510f-4dd4-11dd-93e7-0211d880e350
Discovery 2008-07-07
Entry 2008-07-09

Felipe Andres Manzano reports:

The libpoppler pdf rendering library, can free uninitialized pointers, leading to arbitrary code execution. This vulnerability results from memory management bugs in the Page class constructor/destructor.


CVE Name CVE-2008-2950