FreeBSD VuXML: Documenting security issues in FreeBSD and the FreeBSD Ports Collection

YUI JavaScript library -- JavaScript injection exploits in Flash components

Affected packages
yahoo-ui <= 2.8.2


VuXML ID aa4f86af-3172-11e2-ad21-20cf30e32f6d
Discovery 2012-10-30
Entry 2012-11-27
Modified 2012-11-29

The YUI team reports:

Vulnerability in YUI 2.4.0 through YUI 2.9.0

A XSS vulnerability has been discovered in some YUI 2 .swf files from versions 2.4.0 through 2.9.0. This defect allows JavaScript injection exploits to be created against domains that host affected YUI .swf files.

If your site loads YUI 2 from a CDN (,, etc.) and not from your own domain, you are not affected. YUI 3 is not affected by this issue.


CVE Name CVE-2012-5881
CVE Name CVE-2012-5882