FreeBSD VuXML: Documenting security issues in FreeBSD and the FreeBSD Ports Collection

CVE-2012-3864

This CVE name corresponds to:

Entered Topic
2012-12-30 puppet -- multiple vulnerabilities
2012-07-10 puppet -- multiple vulnerabilities

The following information is adapted from the Common Vulnerabilities and Exposures (CVE) project. CVE and the CVE logo are trademarks of The MITRE Corporation. CVE content is Copyright 2005, The MITRE Corporation.

Details

Type Candidate
Name CVE-2012-3864
Phase Assigned(20120706)

Description

Puppet before 2.6.17 and 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, allows remote authenticated users to read arbitrary files on the puppet master server by leveraging an arbitrary user's certificate and private key in a GET request.

References

Source Reference
CONFIRM http://puppetlabs.com/security/cve/cve-2012-3864/
CONFIRM https://bugzilla.redhat.com/show_bug.cgi?id=839130
CONFIRM https://github.com/puppetlabs/puppet/commit/10f6cb8969b4d5a933b333ecb01ce3696b1d57d4
CONFIRM https://github.com/puppetlabs/puppet/commit/c3c7462e4066bf3a563987a402bf3ddf278bcd87
DEBIAN DSA-2511
SUSE SUSE-SU-2012:0983
UBUNTU USN-1506-1