FreeBSD VuXML: Documenting security issues in FreeBSD and the FreeBSD Ports Collection

x11vnc -- authentication bypass vulnerability

Affected packages
x11vnc < 0.8.2


VuXML ID 9dda3ff1-2b02-11db-a6e2-000e0c2e438a
Discovery 2006-08-08
Entry 2006-08-13

Ludwig Nussel reports that x11vnc is vulnerable to an authentication bypass vulnerability. The vulnerability is caused by an error in auth.c. This could allow a remote attacker to gain unauthorized and unauthenticated access to the system.


Bugtraq ID 18977
CVE Name CVE-2006-2450