FreeBSD VuXML: Documenting security issues in FreeBSD and the FreeBSD Ports Collection

Squid -- Denial of Service Vulnerability

Affected packages
2.0 <= squid < 2.6.16_1
3.* <= squid < 3.0.r1.20071001_1


VuXML ID 6eb580d7-a29c-11dc-8919-001c2514716c
Discovery 2007-11-28
Entry 2007-12-04
Modified 2007-12-07

Squid secuirty advisory reports:

Due to incorrect bounds checking Squid is vulnerable to a denial of service check during some cache update reply processing.

This problem allows any client trusted to use the service to perform a denial of service attack on the Squid service.


Bugtraq ID 26687
CVE Name CVE-2007-6239