FreeBSD VuXML: Documenting security issues in FreeBSD and the FreeBSD Ports Collection

postgresql -- multiple vulnerabilities

Affected packages
7.3 <= postgresql < 7.3.21
7.4 <= postgresql < 7.4.19
8.0 <= postgresql < 8.0.15
8.1 <= postgresql < 8.1.11
8.2 <= postgresql < 8.2.6
7.3 <= postgresql-server < 7.3.21
7.4 <= postgresql-server < 7.4.19
8.0 <= postgresql-server < 8.0.15
8.1 <= postgresql-server < 8.1.11
8.2 <= postgresql-server < 8.2.6


VuXML ID 51436b4c-1250-11dd-bab7-0016179b2dd5
Discovery 2008-01-06
Entry 2008-04-24

The PostgreSQL developers report:

PostgreSQL allows users to create indexes on the results of user-defined functions, known as "expression indexes". This provided two vulnerabilities to privilege escalation: (1) index functions were executed as the superuser and not the table owner during VACUUM and ANALYZE, and (2) that SET ROLE and SET SESSION AUTHORIZATION were permitted within index functions. Both of these holes have now been closed.

PostgreSQL allowed malicious users to initiate a denial-of-service by passing certain regular expressions in SQL queries. First, users could create infinite loops using some specific regular expressions. Second, certain complex regular expressions could consume excessive amounts of memory. Third, out-of-range backref numbers could be used to crash the backend.

DBLink functions combined with local trust or ident authentication could be used by a malicious user to gain superuser privileges. This issue has been fixed, and does not affect users who have not installed DBLink (an optional module), or who are using password authentication for local access. This same problem was addressed in the previous release cycle, but that patch failed to close all forms of the loophole.


Bugtraq ID 27163
CVE Name CVE-2007-4769
CVE Name CVE-2007-4772
CVE Name CVE-2007-6067
CVE Name CVE-2007-6600
CVE Name CVE-2007-6601