FreeBSD VuXML: Documenting security issues in FreeBSD and the FreeBSD Ports Collection

linux-flashplugin -- remote code execution vulnerability

Affected packages
linux-flashplugin <= 9.0r289
linux-f10-flashplugin < 10.2r153
linux-f8-flashplugin < 10.2r153


VuXML ID 501ee07a-5640-11e0-985a-001b2134ef46
Discovery 2011-01-20
Entry 2011-03-24

Adobe Product Security Incident Response Team reports:

A critical vulnerability exists in Adobe Flash Player and earlier versions (Adobe Flash Player and earlier for Chrome users) for Windows, Macintosh, Linux and Solaris operating systems, Adobe Flash Player and earlier versions for Android, and the Authplay.dll component that ships with Adobe Reader and Acrobat X (10.0.1) and earlier 10.x and 9.x versions of Reader and Acrobat for Windows and Macintosh operating systems.

This vulnerability (CVE-2011-0609) could cause a crash and potentially allow an attacker to take control of the affected system. There are reports that this vulnerability is being exploited in the wild in targeted attacks via a Flash (.swf) file embedded in a Microsoft Excel (.xls) file delivered as an email attachment.


CVE Name CVE-2011-0609