FreeBSD VuXML: Documenting security issues in FreeBSD and the FreeBSD Ports Collection

gd -- '_gdGetColors' remote buffer overflow vulnerability

Affected packages
gd < 2.0.35_2,1
php5-gd < 5.2.11_2
php4-gd < 4.4.9_4


VuXML ID 4e8344a3-ca52-11de-8ee8-00215c6a37bb
Discovery 2009-10-15
Entry 2009-11-05
Modified 2010-06-17

CVE reports:

The _gdGetColors function in gd_gd.c in PHP 5.2.11 and 5.3.0, and the GD Graphics Library 2.x, does not properly verify a certain colorsTotal structure member, which might allow remote attackers to conduct buffer overflow or buffer over-read attacks via a crafted GD file, a different vulnerability than CVE-2009-3293.


Bugtraq ID 36712
CVE Name CVE-2009-3546