FreeBSD VuXML: Documenting security issues in FreeBSD and the FreeBSD Ports Collection

phppgadmin -- directory traversal with register_globals enabled

Affected packages
phppgadmin < 4.2.2


VuXML ID 4ce3c20b-124b-11de-a964-0030843d3802
Discovery 2008-12-08
Entry 2009-03-16

Secunia reports:

Dun has discovered a vulnerability in phpPgAdmin, which can be exploited by malicious people to disclose sensitive information.

Input passed via the "_language" parameter to libraries/ is not properly sanitised before being used to include files. This can be exploited to include arbitrary files from local resources via directory traversal attacks and URL-encoded NULL bytes.


Bugtraq ID 32670
CVE Name CVE-2008-5587