FreeBSD VuXML: Documenting security issues in FreeBSD and the FreeBSD Ports Collection

libmspack -- infinite loop denial of service

Affected packages
libmspack <= 0.0.20060920
cabextract < 1.3


VuXML ID 43024078-9b63-11df-8983-001d60d86f38
Discovery 2010-07-26
Entry 2010-07-30

There is a denial of service vulnerability in libmspack. The libmspack code is built into cabextract, so it is also vulnerable.

Secunia reports:

The vulnerability is caused due to an error when copying data from an uncompressed block (block type 0) and can be exploited to trigger an infinite loop by tricking an application using the library into processing specially crafted MS-ZIP archives.