FreeBSD VuXML: Documenting security issues in FreeBSD and the FreeBSD Ports Collection

upnp -- multiple vulnerabilities

Affected packages
upnp < 1.6.18


VuXML ID 2ea6ce3d-6afd-11e2-9d4e-bcaec524bf84
Discovery 2012-11-21
Entry 2013-01-30

Project changelog reports:

This patch addresses three possible buffer overflows in function unique_service_name().The three issues have the folowing CVE numbers:

Notice that the following issues have already been dealt by previous work:


CVE Name CVE-2012-5958
CVE Name CVE-2012-5959
CVE Name CVE-2012-5960
CVE Name CVE-2012-5961
CVE Name CVE-2012-5962
CVE Name CVE-2012-5963
CVE Name CVE-2012-5964
CVE Name CVE-2012-5965