FreeBSD VuXML: Documenting security issues in FreeBSD and the FreeBSD Ports Collection

databases/postgresql*-client -- multiple vulnerabilities

Affected packages
postgresql-client < 8.3.18
8.4 <= postgresql-client < 8.4.11
9 <= postgresql-client < 9.0.7
9.1 <= postgresql-client < 9.1.3


VuXML ID 174b8864-6237-11e1-be18-14dae938ec40
Discovery 2012-02-27
Entry 2012-02-28

The PostgreSQL Global Development Group reports:

These vulnerabilities could allow users to define triggers that execute functions on which the user does not have EXECUTE permission, allow SSL certificate spoofing and allow line breaks in object names to be exploited to execute code when loading a pg_dump file.


CVE Name CVE-2012-0866
CVE Name CVE-2012-0867
CVE Name CVE-2012-0868