FreeBSD VuXML: Documenting security issues in FreeBSD and the FreeBSD Ports Collection

kdelibs -- kimgio input validation errors

Affected packages
3.2 <= kdelibs < 3.4.0_2


VuXML ID 06404241-b306-11d9-a788-0001020eed82
Discovery 2005-04-21
Entry 2005-04-22

A KDE Security Advisory reports:

kimgio contains a PCX image file format reader that does not properly perform input validation. A source code audit performed by the KDE security team discovered several vulnerabilities in the PCX and other image file format readers, some of them exploitable to execute arbitrary code.

Impact: Remotely supplied, specially crafted image files can be used to execute arbitrary code.


CVE Name CVE-2005-1046